[EventCalendar] Error on "Write Post" Page in WP 2.3.2

Alex Tingle alex at firetree.net
Fri Dec 5 22:18:49 UTC 2008


On 5 Dec 2008, at 18:19, Michael Sweeney wrote:

> When you say "apply the patch" do you mean just copying admin- 
> wp23.diff to the plugin folder?

No, it's a diff file - a human and machine readable description of the  
change. You can automatically apply it by using the patch program,  
something like this:

  patch admin.php < admin-wp23.diff

But since it's just adding a single line, you might as well just open  
admin.php in an editor and make the change by hand.

More about patches here:
http://wiki.creativecommons.org/HOWTO_Patch
http://penguin.firetree.net/pipermail/eventcalendar/2008-October/003427.html

-Alex

--

> Alex Tingle wrote:
>> Hi Michael,
>>
>> Thanks for the log-in. I think I can see the problem. You'll need  
>> to apply
>> this patch (see attachment)... just add one line to admin.php.
>>
>> Please let me know if it fixes the problem.
>>
>> -Alex
>>
>> --
>>
>> Michael Sweeney wrote:
>>
>>> I've just disabled all of the plugins and I'm still getting the
>>> problem.  I'll email you offline about a temporary admin account.
>>>
>>> Alex Tingle wrote:
>>>
>>>> Hi Michael,
>>>>
>>>> Michael Sweeney wrote:
>>>>
>>>>> 2.3.2
>>>>> I honestly don't remember what version of EC I was previously  
>>>>> using.
>>>>> http://stlhops.com  But it's working fine on the front page.   
>>>>> I'm only
>>>>> having issues in any of the editing pages.
>>>>>
>>>> Sorry to hear you are having trouble.
>>>>
>>>> WP is failing when it tries to call a plug-in's filter. I can't see
>>>> why you
>>>> should be having this problem with WP2.3 - EC isn't doing  
>>>> anything new
>>>> in this
>>>> regard. Are you sure that it's EC that's causing the problem?  
>>>> Have you
>>>> tried
>>>> disabling other plug-ins?
>>>>
>>>> The first thing I would suggest is to upgrade your Wordpress.  
>>>> Lots of
>>>> quite
>>>> horrible bugs have been fixed since 2.3. (If you do upgrade WP,  
>>>> and it
>>>> does
>>>> fix your problem with EC, then please let us know.)
>>>>
>>>> If upgrading WP isn't an option, then you'll have to give me much  
>>>> more
>>>> detail
>>>> about where the problem occurs. Can you post screen-shots, or just
>>>> give me a
>>>> temporary admin account?
>>>>
>>>> -Alex
>>>>
>>>> -- 
>>>>
>>>>
>>>>> Rick Boatright wrote:
>>>>>
>>>>>> what version of wordpress?
>>>>>> what old version of EC3?
>>>>>> What url so we can take a look?
>>>>>>
>>>>>> Rick
>>>>>>
>>>>>>
>>>>>> On Fri, Dec 5, 2008 at 8:50 AM, Michael Sweeney <mikesweeney at gmail.com
>>>>>> <mailto:mikesweeney at gmail.com>> wrote:
>>>>>>
>>>>>>   I recently upgraded from an old version of EC and now I have  
>>>>>> this
>>>>>>   error where Event Calendar used to be:
>>>>>>
>>>>>>   Warning: call_user_func_array() [function.call-user-func- 
>>>>>> array]:
>>>>>>   First argumented is expected to be a valid callback, 'Array'  
>>>>>> was
>>>>>>   given in  stlhops/wp-includes/plugin.php on line 164
>>>>>>
>>>>>>   Any help?
>>>>>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> Blog: http://wpcal.firetree.net/
>> EventCalendar at firetree.net mailing list
>> Unsubscribe: http://penguin.firetree.net/eventcalendar




More information about the EventCalendar mailing list