[EventCalendar] Event Posting vs. Event Date

Jeff Dodson jeff at singularmarketing.com
Sun Feb 1 07:21:30 UTC 2009


Hello,

Running wp 2.7.1 and EC 3.2b2 (dated January 25th)(and fresh download just
now)

I believe the following things are related, so I will present them together.

All big calendar related:

1. From any large month link at the top left of the calendar, you are taken
to a page that should show the events listed by event date, but they are
listed by post date instead.  I know this has been reported, but not sure
how recently.  I searched the archive and found mentions a couple years old,
so like I said, not sure if this is a recent mention or not.  Back then this
kind of thing was resolved by "keeping events separate", but this is how I
am configured and am still having this issue.

Clicking the February link in my site for example goes to this link:

http://www.fortbendbuyersagent.com/2009/02/?ec3_listing=events

2. The post calendar links from a date for which I posted an event, the POST
date in the calendar becomes clickable.  Now keep in mind I have EC set to
"keep events separate".  Clicking on that clickable link then takes me to
the 404 page, it does not exist, rightly so.  

Here is the link accessible from the article calendar (bottom right). The
event was posted on the 25th and occurred on the 31st.  It is clickable from
the 25th and should not be clickable at all from the post calendar, right?

http://www.fortbendbuyersagent.com/2009/01/25/

3. For the event mentioned in #2, recall it was posted on the 25th and
occurred on the 31st.  On the 31st, I posted an article.  If I click on the
link from the post calendar on the 31st, I should only see the post I made
that day.  But I ALSO see the event POSTED on the 25th but occurring the
31st.  The event date of the 31st caused the event post to be seen in the
post calendar the day the event occurred.  This event did not show in the
post calendar until its scheduled date to occur.

I posted an event today (Feb 1st) that is scheduled to occur on Feb 7th.
The link in the post calendar for the Feb 1st is clickable but goes to a 404
page just as the link from Jan 25th does as described above.  The event
itself does not appear on the post calendar for the 7th, but presumably will
once the 7th arrives, just as the other event posted the 25th and occurring
the 31st showed up on the post calendar once the event happened.
-------
Seems all these are related to keeping events separate being strictly
enforced (or not).  Some "keep events separate" items are working, for
example, event posts do not show on my blog-on-static-page: /articles

Fabulous plugin Alex!

Jeff Dodson




More information about the EventCalendar mailing list