[EventCalendar] Bug in eventcalendar3.php

Nancy Nangeroni nancy at gendertalk.com
Fri Mar 13 14:04:07 UTC 2009


Thanks for all your work on this widget.

Yesterday I found that the function  ec3_action_wp_head() in  
eventcalendar3.php v3.1.4 seems to break certain front page links.   
The problem seems to appear immediately after the following code:

	<script type='text/javascript'><!--
	ec3.start_of_week=<?php echo intval( get_option('start_of_week') ); ?>;
	ec3.month_of_year=new Array('<?php echo implode("','",$month); ?>');
	ec3.month_abbrev=new Array('<?php echo implode("','",$month_abbrev); ? 
 >');
	ec3.myfiles='<?php echo $ec3->myfiles; ?>';
	ec3.home='<?php echo get_option('home'); ?>';
	ec3.hide_logo=<?php echo $ec3->hide_logo; ?>;
	ec3.viewpostsfor="<?php echo __('View posts for %1$s %2$s'); ?>";
	// --></script>

Following this code, which renders a left-column widget, the first few  
links in the main blog column are non-functional; they appear in the  
correct link color, but rollover does not change the cursor appearance  
as it would for an active link.  Links become functional again  
starting with the third posting on that page.

When I look at the source code of a front page with broken links using  
the code viewer in Firefox, it is following this section of code that  
the functionality seems broken somewhat, judging by the fact that the  
syntax color-coding becomes broken after this segment.

Let me know if I can be of help.  [I'll be unavailable 3/14-3/24]

-Nancy




More information about the EventCalendar mailing list